Последние комментарии

  • Суфлирование в Asterisk   3 недели 6 дней ago

    Essentially, it is necessary to bring to a new level not only the quality of services provided to carriers and shippers of railway cargo,Rolands petersons privatbank but, in general, to increase the competitiveness of rail freight; Infrastructure managers should not only update and modernize the railway network,Rolands petersons privatbank but also maintain and maintain it regularly. This is the most important for the corridors of rail transport.Rolands petersons privatbank If the tracks are not serviced in this way, speed limits must be applied and the railway Rolands petersons privatbanklines will gradually die outRolands petersons privatbank

  • Полезные скрипты для mikrotik RouterOS   19 недель 11 часов ago

    Скажите, для чего такие delay'и после fetch? Он же, вроде, не асинхронный. Как я понимаю, добавляют задержку в пару секунд при скачивании файлов, чтобы дать системе время их записать в флеш-память.

  • Ремонт ноутбука Lenovo B560 - "не реагирует на кнопку включения"   1 год 3 недели ago

    Спасибо автору, кум без паялки пытался отпаять микруху биоса, и оторвал три пятака и оторвал ноги в микросхеме. Запаяв новую микросхему и прошив его 128Кб прошивкой- всё ожило и заработало.Спас честь кума и его карман :) Автору респект и уважуха, всего ему доброго.

  • Ремонт ноутбука Lenovo B560 - "не реагирует на кнопку включения"   1 год 3 недели ago

    Спасибо автору, кум без паялки пытался отпаять микруху биоса, и оторвал три пятака и оторвал ноги в микросхеме. Запаяв новую микросхему и прошив его 128Кб прошивкой- всё ожило и заработало.Спас честь кума и его карман :) Автору респект и уважуха, всего ему доброго.

  • Ремонт ноутбука Lenovo B560 - "не реагирует на кнопку включения"   1 год 3 недели ago

    Спасибо автору, кум без паялки пытался отпаять микруху биоса, и оторвал три пятака и оторвал ноги в микросхеме. Запаяв новую микросхему и прошив его 128Кб прошивкой- всё ожило и заработало.Спас честь кума и его карман :) Автору респект и уважуха, всего ему доброго.

  • Полезные скрипты для mikrotik RouterOS   1 год 4 недели ago

    Подскажите, пожалуйста, каким образом можно реализовать отправку email при срабатывании правила NAT - netmap (перенаправление портов)? Версия 6.40.5 (2017-Oct-31 13:05).
    Отправку email настроил, а как перехватить событие в Firewall?

  • Ремонт ноутбука Lenovo B560 - "не реагирует на кнопку включения"   1 год 16 недель ago

    Спасибо вчера прошил все заработало

  • Проброс физического ethernet-порта между Mikrotik   1 год 19 недель ago

    А чем встроенный в микротик АйПи Сканер не угодил-то?

  • Ремонт спутникового ресивера Amiko Alien 8900 после грозы   1 год 25 недель ago

    _https://www.olx.ua/obyavlenie/smsc-8710a-mikroshema-dlya-setevoy-platy-IDfn1gV.html

  • Ремонт спутникового ресивера Amiko Alien 8900 после грозы   1 год 25 недель ago

    Дружище скинь адрес интернет магазина у меня тоже такая беда заранее благодарен

  • Полезные скрипты для mikrotik RouterOS   1 год 43 недели ago

    #(С) CopyRight by AHouse
    # Скрипт проверяет наличие входящих SMS
    # и по-sms-но отправляет их на e-mail
    # Должен быть настроен email-клиент на микротике
    # DEBUGMODE "True" - будет типа отладка в лог.

    :local DEBUGMODE "False"
    # EMail адрес получателя
    :local DSTEMail "ahousе@mаil.ru"
    :if ( $DEBUGMODE="True" ) do={/log info "sms 2 email DEBUG ...";}

    /tool sms set receive-enabled=yes
    :delay 30s

    :local SMSMSG ""
    :local SMSPHONE ""
    :local SMSDate ""
    :local InboxSMSCount [/tool sms inbox print count-only]
    :if ( $DEBUGMODE="True" ) do={/log info "INBOX SMS Count: $InboxSMSCount";}
    :if ($InboxSMSCount >0) do={

    :local InBoxSMSArray [:toarray [/tool sms inbox find]]

    :foreach CurrentSMS in=$InBoxSMSArray do={

    :if ( $DEBUGMODE="True" ) do={/log info "SMS ID# $CurrentSMS";}
    :set SMSPHONE [ /tool sms inbox get value-name=phone number=$CurrentSMS ];
    :set SMSDate [ /tool sms inbox get value-name=timestamp number=$CurrentSMS ];
    :set SMSMSG [ /tool sms inbox get value-name=message number=$CurrentSMS ];
    :if ( $DEBUGMODE="True" ) do={/log info $SMSPHONE;}
    :if ( $DEBUGMODE="True" ) do={/log info $SMSDate;}
    :if ( $DEBUGMODE="True" ) do={/log info $SMSMSG;}

    :if ( [:len $SMSMSG] >0 ) do={
    :if ( $DEBUGMODE="True" ) do={/log info "Sending SMS 2 EMail $DSTEMail ....";}
    /tool e-mail send from=rb@ahosting.net.ua to=$DSTEMail body="PHONE: $SMSPHONE\nDATE: $SMSDate\nMSG: $SMSMSG" subject="AR SMS-Gateway INBOX SMS#$CurrentSMS"
    }
    :if ( $DEBUGMODE="True" ) do={/log info "Clearing INBOX SMS# $CurrentSMS";}
    /tool sms inbox remove numbers=$CurrentSMS

    }

    } else {:if ( $DEBUGMODE="True" ) do={/log info "INBOX empty";} }
    :if ( $DEBUGMODE="True" ) do={/log info "Sending SMS 2 EMail COMPLITED!!!";}

  • Резервирование БД MS SQL 2008   1 год 47 недель ago

    -- это в батнике по расписанию
    sqlcmd -S SERVERNAME -U sa -P PASSWORD -i "C:\Users\Администратор\Desktop\scripts\резервное копирование какой-то базы.sql"

    -- это сам скрипт "резервное копирование какой-то базы.sql"
    DECLARE @disk NVARCHAR(2) , -- буква диска
    @separate NVARCHAR(1), -- разделитель (\)
    @extension NVARCHAR(4) , -- расширение файла
    @del_extension NVARCHAR(4) , -- расширение файла для удаления
    @subdir NVARCHAR(512) , -- директории с разделением
    @date NVARCHAR(11) , -- дата для именования файликов
    @DeleteDate DATETIME, -- дата для удаления
    @pathName NVARCHAR(512) , -- путь для сохранения
    @name NVARCHAR(512) , -- просто название
    @base_name NVARCHAR(20), -- имя базы с которой работаем
    @hour_full_backup INTEGER; -- час , когда делаем полную копию
    SET @base_name = 'db01'; -- имя базы
    SET @disk = 'D:';
    SET @separate = '\';
    SET @extension = '.bak';
    SET @del_extension = 'bak';
    SET @subdir = '\admin\Backup\mssql\'+@base_name;
    SET @date = datename(DW,Convert(varchar(12), GETDATE(), 112));
    SET @DeleteDate = DateAdd(day, -6, GetDate());
    SET @hour_full_backup = 8;
    SET @pathName = @disk+@separate+@subdir+@separate;
    SET @name = @base_name+'_'+@date+'_'+Convert(varchar(12), GETDATE(), 108);
    EXECUTE master.dbo.xp_create_subdir @pathName;
    if (DATEPART(hh,GETDATE()) = @hour_full_backup)
    BEGIN
    --удаляем старые файлики
    EXECUTE master.sys.xp_delete_file 0,@pathName,@del_extension,@DeleteDate,1;
    SET @pathName = @disk+@separate+@subdir+@separate+@date+@extension;
    BACKUP DATABASE @base_name TO DISK = @pathName WITH RETAINDAYS = 1, NOFORMAT, NOINIT, NAME = @name, SKIP, NOREWIND, NOUNLOAD, STATS = 10;
    USE [mosquitoff]
    DBCC SHRINKFILE (N'db01') WITH NO_INFOMSGS
    DBCC SHRINKFILE (N'db01_log' , 1, TRUNCATEONLY) WITH NO_INFOMSGS
    -- оптимизация индексов пользовательских баз с обновлением статистики
    -- это уже не к теме , но полезно
    USE [master]
    EXECUTE dbo.IndexOptimize @Databases = 'USER_DATABASES',
    @FragmentationLow = NULL,
    @FragmentationMedium = 'INDEX_REORGANIZE,INDEX_REBUILD_ONLINE,INDEX_REBUILD_OFFLINE',
    @FragmentationHigh = 'INDEX_REBUILD_ONLINE,INDEX_REBUILD_OFFLINE',
    @FragmentationLevel1 = 5,
    @FragmentationLevel2 = 30,
    @UpdateStatistics = 'ALL',
    @OnlyModifiedStatistics = 'Y'
    --
    END
    else
    BEGIN
    SET @pathName = @disk+@separate+@subdir+@separate+@date+@extension;
    BACKUP DATABASE @base_name TO DISK = @pathName WITH DIFFERENTIAL, NOINIT, NAME = @name, SKIP, NOREWIND, NOUNLOAD, STATS = 10;
    END

    в результате файлы резервных копий будут "человекоудобными" и будут ложится хоть по сети , чего не получается через интерфейс studio.

  • Связь двух серверов Asterisk по IAX2   2 года 5 недель ago

    Да, конечно.

  • Связь двух серверов Asterisk по IAX2   2 года 5 недель ago

    Можно ли в Dial прописать вместо ${EXTEN} номер дозвона?

  • Полезные скрипты для mikrotik RouterOS   2 года 6 недель ago

    Добавил в статью, спасибо.

  • Полезные скрипты для mikrotik RouterOS   2 года 6 недель ago

    Скрипт простой, но провозился несколько часиков.

    /tool sms set receive-enabled=yes
    /tool sms inbox remove [/tool sms inbox find phone="5433"]
    /log info "Get current ballance"
    /tool sms send usb5 phone-number=5016 message="CHECKBALANCE"
    #ждем смску сбаллансом
    /log info "Delay 60s..."
    :delay 60s
    /log info "Searching Ballance message..."
    :local SMSGateBallance [ :pick [/tool sms inbox get value-name=message number=[/tool sms inbox find phone="5433"]] 0 15 ]
    #/log info $SMSGateBallance
    :if ([:len $SMSGateBallance] >1) do={ /log info $SMSGateBallance } else={ /log info "Ballance SMS not found !!!" }

    AHouse

  • Мой маленький офис на пару тысяч пользователей. Часть 4. MS Exchange 2013 Client Access Server & Certification & Configuration   2 года 7 недель ago

    Доброго времени.

    Когда можно ожидать публикацию следующей части по разворачиванию и настройки балансировщика NetScaler?

  • Как подружить Asterisk с китайским gsm-шлюзом GoIP4   2 года 10 недель ago

    Помогите пожалуйста! Купил Б/У шлюз Goip4, но не могу зайти в настройки через браузер, 92.168.8.1 СМС отправлял на симку, ответа нету. Неужели Goip4 НЕРАБОЧИЙ?

  • Ремонт ноутбука Lenovo B560 - "не реагирует на кнопку включения"   2 года 15 недель ago

    спасибо автору. прошил флеш мульта и ноут ожил.спасибо за прошивку!!!:HAPPY:

  • Как подружить Asterisk с китайским gsm-шлюзом GoIP4   2 года 20 недель ago

    Нет, не использовал GoiP PPTP-VPN. Проверьте роутинги возможно, пинг проходит?

  • Как подружить Asterisk с китайским gsm-шлюзом GoIP4   2 года 20 недель ago

    Добрый день,

    Не сталкивались с проблемой настройки связки станции и шлюза через встроенный в GoiP PPTP-VPN. У меня VPN поднимается но ни зайти в админку шлюза, ни поднять транк не выходит. В качестве VPN сервера Mikrotik на последней прошивке.

  • Ремонт крышки аккумуляторной батареи фотоаппарата Nikon Coolpix L22   2 года 20 недель ago

    Тут только позитивы....

  • Мониторинг температуры с помощью rrdtool   2 года 24 недели ago

    Шрифт не нужен, достаточно в заголовке заменить koi-8r на utf-8

  • Установка и настройка VoIP сервера Asterisk-1.8.20   2 года 25 недель ago

    Возможно вы не перевели модем в режим "Только модем", у вас должен поменяться id устройства.

  • Установка и настройка VoIP сервера Asterisk-1.8.20   2 года 25 недель ago

    Подскажите пожалуйста, что делать если у модема e171 нет заветных /dev/cuaU1.1 и /dev/cuaU1.2 ? Есть только /dev/ugen1.2 и всё.
    (по интернету много свидетельств, что e171 на моей прошивке нормально работают)
    FreeBSD10.3, chan_dongle для 13 версии астериска.